[BUILD:fail] kdebase4-runtime (Bug #191)


Added by Jeremy Sutherland over 2 years ago. Updated almost 2 years ago.


Status:Closed Start date:09/10/2011
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:KDE
Target version:-
Grimoire:

Description

Scanning dependencies of target kio_nfs
[ 51%] Building CXX object kioslave/nfs/CMakeFiles/kio_nfs.dir/kio_nfs_automoc.o
[ 52%] Building CXX object kioslave/nfs/CMakeFiles/kio_nfs.dir/kio_nfs.o
In file included from /usr/src/kdebase-runtime-4.6.5/kioslave/nfs/kio_nfs.cpp:21:0:
/usr/src/kdebase-runtime-4.6.5/kioslave/nfs/kio_nfs.h:33:21: fatal error: rpc/rpc.h: No such file or directory
compilation terminated.
make2: * [kioslave/nfs/CMakeFiles/kio_nfs.dir/kio_nfs.o] Error 1
make1:
[kioslave/nfs/CMakeFiles/kio_nfs.dir/all] Error 2
make: *
* [all] Error 2
! Problem Detected !

glibc and not kdebase4-runtime


glibc-2.14_rpc.patch - patch from old bugzilla that suppose to fix problem with glibc 2.14 and rpc (511 Bytes) Bor Kraljič, 09/12/2011 03:06 am


Issue hierarchy

Bug #141: [BUILD] Failure Master BugNew

Bug #191: [BUILD:fail] kdebase4-runtimeClosed


Related issues

related to Grimoire - Bug #177: [BUILD:fail] libvirtd Closed 09/09/2011
related to Grimoire - Bug #195: [SOURCE:repository] glibc Closed 09/12/2011

History

Updated by Bor Kraljič over 2 years ago

http://bugs.sourcemage.org/show_bug.cgi?id=15993 <- this is a bug that is caused by glibc 2.14 (version bump was reverted in test grimoire). So please report what is your version of the glibc.

Updated by Jeremy Sutherland over 2 years ago

Grimoire  Section  Spell  Grimoire Version  Installed Version
--------  -------  -----  ----------------  -----------------
Magicus   libs     glibc  2.13-20110912     2.13-20110904

Updated by Bor Kraljič over 2 years ago

Thank you!

OK lets investigate this. Seems that you are using SCM version according to DETAILS:

  if [[ "$GLIBC_CVS" == "y" ]]; then
local GLIBC_VERSION
   GLIBC_VERSION=2.13
    if [[ "${GLIBC_CVS_AUTOUPDATE}" == "y" ]]; then
         VERSION=${GLIBC_VERSION}-$(date +%Y%m%d) && FORCE_DOWNLOAD=on
    else 
         VERSION=${GLIBC_VERSION}
    fi
          SOURCE=$SPELL-${GLIBC_VERSION}.tar.bz2
SOURCE_DIRECTORY=$BUILD_DIRECTORY/$SPELL-${GLIBC_VERSION}
      SOURCE_URL=cvs://:pserver:anoncvs:anoncvs@sources.redhat.com:/cvs/glibc:libc:$SPELL-${GLIBC_VERSION/./_}-branch
   SOURCE_IGNORE=volatile
  else

We are using some anon cvs. According to website (http://www.gnu.org/software/libc/) git is now used. And even http://sources.redhat.com/glibc/ the location of our cvs url is only mentioning git. So I am not really sure what are we pulling with from that cvs url.

I know that you had other spells that had problem with rpc. Such problems are mentioned on old bugzilla: http://bugs.sourcemage.org/show_bug.cgi?id=15991. But that all effects only glibc 2.14 and not 2.13. That leads me to think that glibc SOURCE_URL (for SCM version) is the one to blame. Since we ATM don't support glibc 2.14 this is glibc bug and not kdebase4-runtime.

But anyway this will have to be fixed sooner or later. That is why I am attaching patch from old bugzilla (http://bugs.sourcemage.org/show_bug.cgi?id=15993) that worked for Treeve.

Updated by Jeremy Sutherland over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved
  • Description changed from Scanning dependencies of target kio_nfs [ 51%] Building CXX object kioslave/n... to Scanning dependencies of target kio_nfs [ 51%] Building CXX object kioslave/n... More

Updated by Vlad Glagolev almost 2 years ago

closing the bug

  • Status changed from Resolved to Closed

Also available in: Atom PDF